BCH transactions temporarily unavailable
Incident Report for CEX.IO
Resolved
The issue is now re-solved.
Posted 4 months ago. Dec 03, 2018 - 11:05 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 4 months ago. Nov 15, 2018 - 18:08 UTC
This incident affected: Crypto Withdrawals and Crypto Deposits.