ZIL withdrawals are under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Feb 16, 2021 - 12:21 UTC
Investigating
We are currently investigating this issue.
Posted Feb 14, 2021 - 10:47 UTC
This incident affected: Crypto Withdrawals (ZIL).