CEX.IO under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Oct 07, 2019 - 14:32 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 07, 2019 - 14:14 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 07, 2019 - 14:02 UTC
This incident affected: CEX.IO BROKER (Trading terminal, Account management, Deposits, Withdrawals) and Uptime (Website availability).