ATOM deposits and withdrawals are under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Feb 20, 2021 - 01:31 UTC
Investigating
We are currently investigating this issue.
Posted Feb 19, 2021 - 12:56 UTC
This incident affected: Crypto Withdrawals (ATOM) and Crypto Deposits (ATOM).