CEX.IO Card EURC transactions maintenance

Incident Report for CEX.IO

Resolved

This incident has been resolved.
Posted Dec 07, 2025 - 16:39 UTC

Investigating

We are experiencing issues with EURC payments via CEX.IO Card. Please exchange these assets for other currencies for a successful transaction.
Posted Dec 07, 2025 - 16:15 UTC
This incident affected: CEX.IO Card (Card transactions).