CEX.IO BROKER Account Management under Maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Oct 23, 2019 - 12:44 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 23, 2019 - 12:12 UTC
This incident affected: CEX.IO BROKER (Account management).