ATOM withdrawals are under maintenance.
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted May 10, 2021 - 20:49 UTC
Investigating
We are currently investigating this issue.
Posted May 07, 2021 - 19:22 UTC
This incident affected: Crypto Withdrawals (ATOM).