CEX.IO Verification Flow Disruption

Incident Report for CEX.IO

Resolved

This incident has been resolved.
Posted Nov 25, 2024 - 15:29 UTC

Identified

We are currently experiencing an issue affecting the verification flow on the CEX.IO App. Our team is actively working to resolve it as quickly as possible. We apologize for any inconvenience caused and appreciate your patience.
Posted Nov 25, 2024 - 15:21 UTC

Investigating

We are currently experiencing an issue affecting the verification flow on both web and mobile. Our team is actively working to resolve it as quickly as possible. We apologize for any inconvenience caused and appreciate your patience.
Posted Nov 25, 2024 - 12:40 UTC
This incident affected: Mobile Application and Uptime (Verification).