CEX.IO under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 13, 2019 - 15:19 UTC
Investigating
We are currently investigating this issue.
Posted 3 months ago. Jul 13, 2019 - 13:52 UTC
This incident affected: Crypto Deposits (BTC, LTC, ETH, XRP, XLM, BCH, MHC, BTG, TRX, BTT) and Fiat (Card Deposits, International Bank Transfer (Deposit), Domestic Bank Transfer (Deposit)).