BCH withdrawals are under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Apr 05, 2021 - 16:22 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 04, 2021 - 18:58 UTC
This incident affected: Crypto Withdrawals (BCH).