CEX.IO BROKER under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 8 days ago. Jul 11, 2019 - 00:01 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 8 days ago. Jul 10, 2019 - 23:31 UTC
This incident affected: CEX.IO BROKER (Trading terminal, Account management).