BTC withdrawal maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Apr 20, 2024 - 12:11 UTC
Investigating
We are currently investigating this issue.
Posted Apr 20, 2024 - 06:53 UTC
This incident affected: Crypto Withdrawals (BTC).