XRP deposits/withdrawals under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Oct 08, 2019 - 13:51 UTC
Investigating
We are currently investigating this issue.
Posted Oct 08, 2019 - 13:35 UTC
This incident affected: Crypto Withdrawals (XRP) and Crypto Deposits (XRP).