XRP transactions under maintenance.
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Oct 30, 2019 - 10:22 UTC
Investigating
We are currently investigating this issue.
Posted Oct 30, 2019 - 09:24 UTC
This incident affected: Crypto Withdrawals (XRP) and Crypto Deposits (XRP).