BTC transactions under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jan 09, 2020 - 18:43 UTC
Investigating
We are currently investigating this issue.
Posted Jan 09, 2020 - 17:34 UTC
This incident affected: Crypto Withdrawals (BTC) and Crypto Deposits (BTC).