XLM transactions under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 4 months ago. Dec 04, 2018 - 15:30 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 4 months ago. Dec 04, 2018 - 10:26 UTC
This incident affected: Crypto Withdrawals and Crypto Deposits.