CEX.IO BROKER Deposits Unstable
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 10, 2019 - 19:50 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Jul 09, 2019 - 10:46 UTC
This incident affected: CEX.IO BROKER (Deposits).