BTC withdrawals under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Nov 01, 2019 - 16:52 UTC
Investigating
We are currently investigating this issue.
Posted Nov 01, 2019 - 15:09 UTC
This incident affected: Crypto Withdrawals (BTC).