Deposits to CEX.IO BROKER under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 05, 2019 - 12:19 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 4 months ago. Jul 05, 2019 - 09:28 UTC
This incident affected: CEX.IO BROKER (Account management).