CEX.IO Wallet and Spot trading. High Demand Alert

Incident Report for CEX.IO

Resolved

This incident has been resolved.
Posted Nov 11, 2024 - 22:32 UTC

Identified

We’re currently experiencing some issues with Trade and Wallet services due to high demand. Our team is actively working to get everyone back on track as soon as possible!
Posted Nov 11, 2024 - 21:58 UTC
This incident affected: CEX.IO Spot Trading (Login, Trading) and CEX.IO Wallet.