Vyne Online Banking System maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jun 26, 2023 - 10:52 UTC
Investigating
We are currently investigating this issue.
Posted Apr 14, 2023 - 08:35 UTC
This incident affected: Fiat (Vyne Online Banking System).