ETH transactions under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Dec 27, 2019 - 19:17 UTC
Update
We are continuing to investigate this issue.
Posted Dec 27, 2019 - 18:25 UTC
Investigating
We are currently investigating this issue.
Posted Dec 27, 2019 - 16:53 UTC
This incident affected: Crypto Withdrawals (ETH) and Crypto Deposits (ETH).