ADA transactions under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Dec 23, 2019 - 10:05 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 23, 2019 - 09:34 UTC
This incident affected: Crypto Withdrawals (ADA) and Crypto Deposits (ADA).