MHC deposits/withdrawals under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Oct 29, 2019 - 21:33 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 29, 2019 - 20:58 UTC
This incident affected: Crypto Withdrawals (MHC) and Crypto Deposits (MHC).