CEX.IO and CEX.IO Broker are under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jan 13, 2020 - 12:00 UTC
Identified
The ongoing maintenance may result in degraded performance of both platforms at times.
Posted Jan 13, 2020 - 11:19 UTC
This incident affected: Uptime (Login, Website availability) and CEX.IO BROKER (Account management).