Temporary service issues possible
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jun 21, 2019 - 14:07 UTC
Identified
Due to increased trading activity on the platform, users may experience temporary service issues. Our tech team is working to make your service experience uninterrupted. We apologize for the possible inconvenience.
Posted Jun 16, 2019 - 17:29 UTC
This incident affected: Uptime (Trade Page).