Mobile app under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jun 16, 2019 - 10:41 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 16, 2019 - 07:59 UTC
This incident affected: Uptime (Website availability, Trade Page, Buy/Sell page, Verification).