BTC transactions unstable
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted about 1 month ago. Dec 13, 2018 - 08:58 UTC
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Dec 12, 2018 - 23:34 UTC
This incident affected: Crypto Withdrawals and Crypto Deposits.