LTC transactions maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Nov 30, 2022 - 17:08 UTC
Investigating
We are currently investigating this issue.
Posted Nov 30, 2022 - 16:49 UTC
This incident affected: Crypto Deposits (LTC) and Crypto Withdrawals (LTC).