CEX.IO under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted about 1 month ago. Dec 13, 2018 - 15:10 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. Dec 13, 2018 - 14:58 UTC
This incident affected: Uptime.