Crypto withdrawals are on maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 6 months ago. Dec 13, 2018 - 08:58 UTC
Identified
ETA around 3 hours
Posted 6 months ago. Dec 13, 2018 - 08:53 UTC
This incident affected: Crypto Deposits (LTC).