MHC deposits are under the maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Oct 19, 2021 - 15:52 UTC
Update
We are continuing to investigate this issue.
Posted Oct 19, 2021 - 15:17 UTC
Investigating
We are currently investigating this issue.
Posted Oct 19, 2021 - 14:09 UTC
This incident affected: Crypto Deposits (MHC) and Crypto Withdrawals (MHC).