Affiliate statistics issue
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Oct 18, 2018 - 11:22 UTC
Investigating
We kindly inform you that we are facing some technical issues with Affiliate statistics on October 18, 2018.
Posted Oct 18, 2018 - 07:27 UTC