ETH transactions under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jul 11, 2020 - 23:04 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 11, 2020 - 21:53 UTC
This incident affected: Crypto Withdrawals (ETH) and Crypto Deposits (ETH).