MATIC withdrawals are under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Apr 11, 2021 - 07:50 UTC
Investigating
We are currently investigating this issue.
Posted Apr 10, 2021 - 18:43 UTC
This incident affected: Crypto Withdrawals (MATIC).