CEX.IO is under the maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Apr 05, 2021 - 07:39 UTC
Investigating
We are currently investigating this issue.
Posted Apr 05, 2021 - 06:43 UTC
This incident affected: Uptime (Registrations, Login, Website availability).