We are observing network performance issues with our datacenter provider
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jul 16, 2019 - 14:28 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 16, 2019 - 13:43 UTC
This incident affected: Uptime (Registrations, Login, Website availability).