MATIC withdrawals maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jan 17, 2022 - 08:12 UTC
Investigating
We are currently investigating this issue.
Posted Jan 12, 2022 - 12:11 UTC
This incident affected: Crypto Withdrawals (MATIC).