CEX.IO under maintenance, ETA to be provided
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Oct 14, 2018 - 18:58 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 14, 2018 - 18:44 UTC
This incident affected: Uptime (Website availability).