MHC withdrawals under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 10, 2019 - 15:19 UTC
Investigating
We are currently investigating this issue.
Posted 3 months ago. Jul 10, 2019 - 13:39 UTC
This incident affected: Crypto Withdrawals (MHC).