USD Card Withdrawals Unstable
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 14, 2019 - 10:09 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 7 months ago. Nov 21, 2018 - 09:00 UTC
This incident affected: Fiat (Domestic Bank Transfer (Deposit), Domestic Bank Transfer (Withdrawal)).