ATOM withdrawals are under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Oct 30, 2021 - 13:01 UTC
Investigating
We are currently investigating this issue.
Posted Oct 21, 2021 - 14:05 UTC
This incident affected: Crypto Withdrawals (ATOM).