CEX.IO is under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jul 18, 2021 - 07:56 UTC
Investigating
We are currently investigating this issue.
Posted Jul 18, 2021 - 07:27 UTC
This incident affected: Uptime (Website availability).