CEX.O Mobile App is under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jan 11, 2022 - 05:23 UTC
Investigating
We are currently investigating this issue.
Posted Jan 11, 2022 - 04:05 UTC
This incident affected: Mobile Application.