USD Bank Transfer Withdrawals Unstable
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Feb 21, 2019 - 14:01 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 29, 2019 - 07:49 UTC
Monitoring
USD Bank Transfer Withdrawals under maintenance
Posted Jan 29, 2019 - 07:41 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 24, 2019 - 10:58 UTC