ETH transactions are currently under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jul 31, 2020 - 12:26 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 31, 2020 - 08:11 UTC
This incident affected: Crypto Withdrawals (ETH) and Crypto Deposits (ETH).