BTC Withdrawals Unstable
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 3 months ago. Dec 14, 2018 - 22:57 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Dec 14, 2018 - 22:47 UTC
This incident affected: Crypto Withdrawals.