CEX.IO is under the maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jun 10, 2021 - 21:26 UTC
Investigating
We are currently investigating this issue.
Posted Jun 10, 2021 - 21:12 UTC
This incident affected: Uptime (Website availability).