XRP withdrawals unstable
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jan 03, 2019 - 19:54 UTC
Update
We are continuing to investigate this issue.
Posted Jan 03, 2019 - 18:50 UTC
Investigating
We are currently investigating this issue.
Posted Jan 03, 2019 - 18:32 UTC
This incident affected: Crypto Deposits (LTC).