CEX.IO Login under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Oct 02, 2019 - 15:54 UTC
Investigating
We are currently investigating this issue.
Posted Oct 02, 2019 - 15:39 UTC
This incident affected: 2-Factor Authentication (Phone Call, SMS) and Uptime (Login).